#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w*(?:[A-Za-z]\w*){6,}$"
Local $sString = "abcdef" & @CRLF & _
"abc9def" & @CRLF & _
"_testaa" & @CRLF & _
"__test_aa_" & @CRLF & _
"hello_h_9" & @CRLF & _
"_9helloa" & @CRLF & _
"9a8v6f_aaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")