import re
regex = re.compile(r"^\w*(?:[A-Za-z]\w*){6,}$", flags=re.MULTILINE)
test_str = ("abcdef\n"
"abc9def\n"
"_testaa\n"
"__test_aa_\n"
"hello_h_9\n"
"_9helloa\n"
"9a8v6f_aaa")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")