const regex = /^\w*(?:[A-Za-z]\w*){6,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w*(?:[A-Za-z]\\w*){6,}$', 'gm')
const str = `abcdef
abc9def
_testaa
__test_aa_
hello_h_9
_9helloa
9a8v6f_aaa`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}