use strict;
my $str = 'abcdef
abc9def
_testaa
__test_aa_
hello_h_9
_9helloa
9a8v6f_aaa';
my $regex = qr/^\w*(?:[A-Za-z]\w*){6,}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}