re = /^\w*(?:[A-Za-z]\w*){6,}$/m
str = 'abcdef
abc9def
_testaa
__test_aa_
hello_h_9
_9helloa
9a8v6f_aaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end