using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w*(?:[A-Za-z]\w*){6,}$";
string input = @"abcdef
abc9def
_testaa
__test_aa_
hello_h_9
_9helloa
9a8v6f_aaa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}