#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d\d?\/\d\d?\/(\d\d)?\d\d\s\d\d?:\d\d"
Local $sString = "1/1/17 1:10" & @CRLF & _
"10/10/201701:10" & @CRLF & _
"1/1/17 1:10" & @CRLF & _
"10/10/2017 01:10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")