import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d\\d?\\/\\d\\d?\\/(\\d\\d)?\\d\\d\\s\\d\\d?:\\d\\d";
final String string = "1/1/17 1:10\n"
+ "10/10/201701:10\n"
+ "1/1/17 1:10\n"
+ "10/10/2017 01:10";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}