$re = '/\d\d?\/\d\d?\/(\d\d)?\d\d\s\d\d?:\d\d/';
$str = '1/1/17 1:10
10/10/201701:10
1/1/17 1:10
10/10/2017 01:10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);