package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d\d?\/\d\d?\/(\d\d)?\d\d\s\d\d?:\d\d`)
var str = `1/1/17 1:10
10/10/201701:10
1/1/17 1:10
10/10/2017 01:10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}