re = /\d\d?\/\d\d?\/(\d\d)?\d\d\s\d\d?:\d\d/
str = '1/1/17 1:10
10/10/201701:10
1/1/17 1:10
10/10/2017 01:10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end