using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d\d?\/\d\d?\/(\d\d)?\d\d\s\d\d?:\d\d";
string input = @"1/1/17 1:10
10/10/201701:10
1/1/17 1:10
10/10/2017 01:10";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}