#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\w+(?: \w+)*(?: \([^()]*\))?) (\d+|[¼½¾]) (\w+(?: \w+)*)$"
Local $sString = "A sample string 20 something" & @CRLF & _
"Some text (just as 1 example) 2 more words" & @CRLF & _
"Some text (just as ¼ example) ¼ more words" & @CRLF & _
"A sample string ½ something" & @CRLF & _
"" & @CRLF & _
"Some text (just as ¼ example) ¼ more words"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")