import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+(?: \\w+)*(?: \\([^()]*\\))?) (\\d+|[¼½¾]) (\\w+(?: \\w+)*)$";
final String string = "A sample string 20 something\n"
+ "Some text (just as 1 example) 2 more words\n"
+ "Some text (just as ¼ example) ¼ more words\n"
+ "A sample string ½ something\n\n"
+ "Some text (just as ¼ example) ¼ more words";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}