package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+(?: \w+)*(?: \([^()]*\))?) (\d+|[¼½¾]) (\w+(?: \w+)*)$`)
var str = `A sample string 20 something
Some text (just as 1 example) 2 more words
Some text (just as ¼ example) ¼ more words
A sample string ½ something
Some text (just as ¼ example) ¼ more words`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}