re = /^(\w+(?: \w+)*(?: \([^()]*\))?) (\d+|[¼½¾]) (\w+(?: \w+)*)$/m
str = 'A sample string 20 something
Some text (just as 1 example) 2 more words
Some text (just as ¼ example) ¼ more words
A sample string ½ something
Some text (just as ¼ example) ¼ more words'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end