// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\w+(?: \w+)*(?: \([^()]*\))?) (\d+|[¼½¾]) (\w+(?: \w+)*)$").unwrap();
let string = "A sample string 20 something
Some text (just as 1 example) 2 more words
Some text (just as ¼ example) ¼ more words
A sample string ½ something
Some text (just as ¼ example) ¼ more words";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}