const regex = new RegExp('^(\\w+(?: \\w+)*(?: \\([^()]*\\))?) (\\d+|[¼½¾]) (\\w+(?: \\w+)*)$', 'gm')
const str = `A sample string 20 something
Some text (just as 1 example) 2 more words
Some text (just as ¼ example) ¼ more words
A sample string ½ something
Some text (just as ¼ example) ¼ more words`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}