# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?)\((\d*?)\)/\1+\2/g;t' <<< "08.070.838/0001-63.offset(1)"