$re = '/(.*?)\((\d*?)\)/';
$str = '08.070.838/0001-63.offset(1)';
$subst = "\1+\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;