use strict;
my $str = '08.070.838/0001-63.offset(1)';
my $regex = qr/(.*?)\((\d*?)\)/p;
my $subst = '\\1+\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";