#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.*?)\((\d*?)\)"
Local $sString = "08.070.838/0001-63.offset(1)"
Local $sSubst = "\1+\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)