re = /(.*?)\((\d*?)\)/
str = '08.070.838/0001-63.offset(1)'
subst = '\\1+\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result