#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\d+$)(?!\w+-\d+$).*$"
Local $sString = "1223434-qasas" & @CRLF & _
"asasas1111" & @CRLF & _
"1223434-qasas" & @CRLF & _
"sasas1111" & @CRLF & _
"11111111" & @CRLF & _
"asasa-1111" & @CRLF & _
"11111111" & @CRLF & _
"testing_-1" & @CRLF & _
"testing_1" & @CRLF & _
"asasasas-11111" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")