use strict;
my $str = '1223434-qasas
asasas1111
1223434-qasas
sasas1111
11111111
asasa-1111
11111111
testing_-1
testing_1
asasasas-11111
';
my $regex = qr/^(?!\d+$)(?!\w+-\d+$).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}