const regex = /^(?!\d+$)(?!\w+-\d+$).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\d+$)(?!\\w+-\\d+$).*$', 'gm')
const str = `1223434-qasas
asasas1111
1223434-qasas
sasas1111
11111111
asasa-1111
11111111
testing_-1
testing_1
asasasas-11111
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}