import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\d+$)(?!\\w+-\\d+$).*$";
final String string = "1223434-qasas\n"
+ "asasas1111\n"
+ "1223434-qasas\n"
+ "sasas1111\n"
+ "11111111\n"
+ "asasa-1111\n"
+ "11111111\n"
+ "testing_-1\n"
+ "testing_1\n"
+ "asasasas-11111\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}