re = /^(?!\d+$)(?!\w+-\d+$).*$/m
str = '1223434-qasas
asasas1111
1223434-qasas
sasas1111
11111111
asasa-1111
11111111
testing_-1
testing_1
asasasas-11111
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end