using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\d+$)(?!\w+-\d+$).*$";
string input = @"1223434-qasas
asasas1111
1223434-qasas
sasas1111
11111111
asasa-1111
11111111
testing_-1
testing_1
asasasas-11111
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}