#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(TIM[\d]{4}-[\d]+ [|]) ([\d]{6}[.][\w]+[/d]*) ([\w]+-?\d*)(.*)"
Local $sString = "TIM2020-001 | 200224.T7 Ia-8" & @CRLF & _
"TIM2020-001 | 200224.T7 Gr" & @CRLF & _
"TIM2020-001 | 200224.T77 Gr" & @CRLF & _
"TIM2020-001 | 20024.T7 Gr"
Local $sSubst = "$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)