import re
regex = re.compile(r"(TIM[\d]{4}-[\d]+ [|]) ([\d]{6}[.][\w]+[/d]*) ([\w]+-?\d*)(.*)", flags=re.MULTILINE)
test_str = ("TIM2020-001 | 200224.T7 Ia-8\n"
"TIM2020-001 | 200224.T7 Gr\n"
"TIM2020-001 | 200224.T77 Gr\n"
"TIM2020-001 | 20024.T7 Gr")
subst = "$3"
result = regex.sub(subst, test_str)
if result:
print(result)