package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(TIM[\d]{4}-[\d]+ [|]) ([\d]{6}[.][\w]+[/d]*) ([\w]+-?\d*)(.*)`)
var str = `TIM2020-001 | 200224.T7 Ia-8
TIM2020-001 | 200224.T7 Gr
TIM2020-001 | 200224.T77 Gr
TIM2020-001 | 20024.T7 Gr`
var substitution = "$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}