re = /(TIM[\d]{4}-[\d]+ [|]) ([\d]{6}[.][\w]+[\/d]*) ([\w]+-?\d*)(.*)/m
str = 'TIM2020-001 | 200224.T7 Ia-8
TIM2020-001 | 200224.T7 Gr
TIM2020-001 | 200224.T77 Gr
TIM2020-001 | 20024.T7 Gr'
subst = '$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result