import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(TIM[\\d]{4}-[\\d]+ [|]) ([\\d]{6}[.][\\w]+[/d]*) ([\\w]+-?\\d*)(.*)";
final String string = "TIM2020-001 | 200224.T7 Ia-8\n"
+ "TIM2020-001 | 200224.T7 Gr\n"
+ "TIM2020-001 | 200224.T77 Gr\n"
+ "TIM2020-001 | 20024.T7 Gr";
final String subst = "$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}