using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(TIM[\d]{4}-[\d]+ [|]) ([\d]{6}[.][\w]+[/d]*) ([\w]+-?\d*)(.*)";
string substitution = @"$3";
string input = @"TIM2020-001 | 200224.T7 Ia-8
TIM2020-001 | 200224.T7 Gr
TIM2020-001 | 200224.T77 Gr
TIM2020-001 | 20024.T7 Gr";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}