#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bSpecialDay\b"
Local $sString = "hey! Hello World. SpecialDayForMe" & @CRLF & _
"hey! Hello World. SpecialDay ForMe" & @CRLF & _
"Hello world. SpecialDay" & @CRLF & _
"Hello world. SpecialDay. It certainly is"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")