package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bSpecialDay\b`)
var str = `hey! Hello World. SpecialDayForMe
hey! Hello World. SpecialDay ForMe
Hello world. SpecialDay
Hello world. SpecialDay. It certainly is`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}