using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bSpecialDay\b";
string input = @"hey! Hello World. SpecialDayForMe
hey! Hello World. SpecialDay ForMe
Hello world. SpecialDay
Hello world. SpecialDay. It certainly is";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}