re = /\bSpecialDay\b/m
str = 'hey! Hello World. SpecialDayForMe
hey! Hello World. SpecialDay ForMe
Hello world. SpecialDay
Hello world. SpecialDay. It certainly is'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end