import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bSpecialDay\\b";
final String string = "hey! Hello World. SpecialDayForMe\n"
+ "hey! Hello World. SpecialDay ForMe\n"
+ "Hello world. SpecialDay\n"
+ "Hello world. SpecialDay. It certainly is";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}