using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![Ll]ine\b).*\b(TIMEKEEPER|CLIENT|LAW FIRM)\b.*$";
string input = @"Line 1 : Missing required fields
line 2 : No Delimiter
PL is not approved TIMEKEEPER
CLIENT ABC is not authorized
LAW FIRM address is required
address is required
ABC is not authorized";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}