import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![Ll]ine\\b).*\\b(TIMEKEEPER|CLIENT|LAW FIRM)\\b.*$";
final String string = "Line 1 : Missing required fields\n"
+ "line 2 : No Delimiter\n"
+ "PL is not approved TIMEKEEPER\n"
+ "CLIENT ABC is not authorized\n"
+ "LAW FIRM address is required\n"
+ "address is required\n"
+ "ABC is not authorized";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}