re = /^(?![Ll]ine\b).*\b(TIMEKEEPER|CLIENT|LAW FIRM)\b.*$/m
str = 'Line 1 : Missing required fields
line 2 : No Delimiter
PL is not approved TIMEKEEPER
CLIENT ABC is not authorized
LAW FIRM address is required
address is required
ABC is not authorized'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end