const regex = /^(?![Ll]ine\b).*\b(TIMEKEEPER|CLIENT|LAW FIRM)\b.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![Ll]ine\\b).*\\b(TIMEKEEPER|CLIENT|LAW FIRM)\\b.*$', 'gm')
const str = `Line 1 : Missing required fields
line 2 : No Delimiter
PL is not approved TIMEKEEPER
CLIENT ABC is not authorized
LAW FIRM address is required
address is required
ABC is not authorized`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}