using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\\u0027\\u003e\\u003cspan\\u003e\$)(.*)(?=\\u003c)";
string input = @"data-map-flag=\u0027False\u0027\u003e\u003cspan\u003e$321.99\u003c/span\u003e";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}