import Foundation
let pattern = #"(?<=\\u0027\\u003e\\u003cspan\\u003e\$)(.*)(?=\\u003c)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"data-map-flag=\u0027False\u0027\u003e\u003cspan\u003e$321.99\u003c/span\u003e"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)