const regex = new RegExp('(?<=\\\\u0027\\\\u003e\\\\u003cspan\\\\u003e\\$)(.*)(?=\\\\u003c)', 'g')
const str = `data-map-flag=\\u0027False\\u0027\\u003e\\u003cspan\\u003e\$321.99\\u003c/span\\u003e`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}