use strict;
my $str = 'data-map-flag=\\u0027False\\u0027\\u003e\\u003cspan\\u003e$321.99\\u003c/span\\u003e';
my $regex = qr/(?<=\\u0027\\u003e\\u003cspan\\u003e\$)(.*)(?=\\u003c)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}