import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\\\u0027\\\\u003e\\\\u003cspan\\\\u003e\\$)(.*)(?=\\\\u003c)";
final String string = "data-map-flag=\\u0027False\\u0027\\u003e\\u003cspan\\u003e$321.99\\u003c/span\\u003e";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}