re = /(?<=\\u0027\\u003e\\u003cspan\\u003e\$)(.*)(?=\\u003c)/
str = 'data-map-flag=\\u0027False\\u0027\\u003e\\u003cspan\\u003e$321.99\\u003c/span\\u003e'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end